Internet Explorer is not supported, please use Chrome, Safari or Firefox

Some users have reported that our app does not work with Internet Explorer.

We have confirmed that latest versions of IE are not supported.

Please either use Chrome, Safari or Firefox.

Have more questions? Submit a request


Article is closed for comments.
Powered by Zendesk